Shellshock & Apple Macs

For various reasons they’re slow to act, rumour has it that bash is now GPL 3.0 and Apple won’t use that, for various reasons. This shows how to get and compile and install bash

I needed to run a sudo xcodebuild -license. NB Unlike COBOL, there’s no British spelling option.

This article from askunbuntu also documents the code to test the bug.

Related Posts

  • Mavericks a.k.a. MacOS X.9 I said in my article on upgrading MacOS that this was easy to do, it […]
  • Job Control It seems that Mac have begun to decrement cron and recommend the use of launchd for job […]
  • Upgrading MacOS X And on to 10.9 There was a rumour that it was best to stop at 10.8, Mountain Lion but […]
  • EXIF and MacOS X I have listened to Stop 43, and the British Journal of Photography I have read what Tim […]
  • Scripting on the Mac It's UNIX, how hard can it be? I want to run some Macports uodate scripts regularly. To […]

Leave a Reply

Your email address will not be published. Required fields are marked *